Hi Last week managed to set up Nominatim successfully following the instructions provided by OSM. However there was one problem where the gb_postcode database was not created. I think it was because it was using deprecated functions so I have replaced them with the newer alternatives.

I have my postgres user set up as the same user of the computer just as the instructions mention.

I run the following command: ./Nominatim-2.0.0/utils/setup.php --osm-file osmfile.osm.pbf --all

But I get a permissions error as follows:

Using projection SRS 4326 (Latlong)
NOTICE:  table "place" does not exist, skipping
NOTICE:  type "keyvalue" does not exist, skipping
NOTICE:  type "wordscore" does not exist, skipping
NOTICE:  type "stringlanguagetype" does not exist, skipping
NOTICE:  type "keyvaluetype" does not exist, skipping
NOTICE:  function get_connected_ways(pg_catalog.int4[]) does not exist, skipping
Allocating memory for dense node cache
Allocating dense node cache in block sized chunks
Node-cache: cache=1169MB, maxblocks=0*149633, allocation method=8192
Mid: pgsql, scale=10000000 cache=1169
Setting up table: planet_osm_nodes
NOTICE:  table "planet_osm_nodes" does not exist, skipping
NOTICE:  CREATE TABLE / PRIMARY KEY will create implicit index "planet_osm_nodes_pkey" for table "planet_osm_nodes"
Setting up table: planet_osm_ways
NOTICE:  table "planet_osm_ways" does not exist, skipping
NOTICE:  CREATE TABLE / PRIMARY KEY will create implicit index "planet_osm_ways_pkey" for table "planet_osm_ways"
Setting up table: planet_osm_rels
NOTICE:  table "planet_osm_rels" does not exist, skipping
NOTICE:  CREATE TABLE / PRIMARY KEY will create implicit index "planet_osm_rels_pkey" for table "planet_osm_rels"

Reading in file: /home/sam/src/nominatim/Edinburgh.osm.pbf
Processing: Node(460k 153.3k/s) Way(66k 11.02k/s) Relation(820 820.00/s)  parse time: 9s

Node stats: total(460001), max(1955784257) in 3s
Way stats: total(66118), max(184992843) in 6s
Relation stats: total(827), max(2454531) in 0s
node cache: stored: 460001(100.00%), storage efficiency: 2.44% (dense blocks: 18381, sparse nodes: 0), hit rate: 0.00%
Stopping table: planet_osm_nodes
Stopping table: planet_osm_ways
Stopped table: planet_osm_nodes in 0s
Stopping table: planet_osm_rels
Building index on table: planet_osm_rels (fastupdate=off)
Building index on table: planet_osm_ways (fastupdate=off)
Stopped table: planet_osm_rels in 0s
Stopped table: planet_osm_ways in 4s

Osm2pgsql took 17s overall
osm2pgsql SVN version 0.81.0 (32bit id space)

ERROR: DB Error: insufficient permissions
DB Error: insufficient permissions

I have ran the chmod +x command on all the directories mentioned in the instructions.

I don't understand why this error occurs. I managed to run the command last week but I can't think of what has changed.

Can anyone help?

Thanks

asked 28 Jan '13, 01:19

srose's gravatar image

srose
146101015
accept rate: 0%


I manged to fix this. Turns out I was using the wrong username in the local.php file. Not sure how this worked before.

permanent link

answered 28 Jan '13, 16:43

srose's gravatar image

srose
146101015
accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×454
×451
×102
×93

question asked: 28 Jan '13, 01:19

question was seen: 3,487 times

last updated: 28 Jan '13, 16:43

powered by OSQA