I saw a similar question asked and the answer was not an answer, rather just a statement that this question gets asked frequently and a suggestion to "go search on Garmin" and find out about all of its options. That is NOT VERY MUCH to search on! Hopefully, someone can help a little more.

I am new to my Garmin 62S, new to OpenStreetMap, new to this forum.

I was able to figure out how to generate a "routeable map", a topo map, and the Garmin came with a Garmin North Am. City Map. I have all these maps on the device and can enable them, but the street maps do not show streets no matter what the level of zoom and the topo map does not show topo lines. I am using Mapsource to get the maps onto the device and I have the "topo shading option" set to DO NOT DISPLAY. Feeling pretty ignorant. What is it that I am missing? Appreciate any help or direction. I have invested some hours searching for answers already. Thanks.

I am always disabling all maps except the one I am testing. I am not trying multiple active maps. Remember, I have City Navigator N. America on and Basecamp recognizes it and lists it under the DEVICES label when it detects the 62S. Interstate highways are shown immediately on Basecamp and I can zoom down to streets with no problem, but I cannot on the 62S and can't even see the interstate highways. Got to be something simple and basic.

asked 13 Jan '13, 22:57

aj_chicago's gravatar image

aj_chicago
41112
accept rate: 0%

edited 17 Jan '13, 13:25

SK53's gravatar image

SK53 ♦
22.6k46229355

I am always disabling all maps except the one I am testing. I am not trying multiple active maps. Remember, I have City Navigator N. America on and Basecamp recognizes it and lists it under the DEVICES label when it detects the 62S. Interstate highways are shown immediately on Basecamp and I can zoom down to streets with no problem, but I cannot on the 62S and can't even see the interstate highways. Got to be something simple and basic.

(14 Jan '13, 15:52) aj_chicago
1

Hi aj_chicago it's good to get feedback,maybe worthwhile changing your update into an answer?

(17 Jan '13, 09:37) andy mackey

There's a few different things which can go wrong, so it's hard to tell.

  • Try using a ready-made non-topo map, to make sure it isn't an issue with the file you created.
  • Try copying the .IMG file onto your device's "garmin" directory directly (by using it as a usb key) instead of using mapsource.
  • Try disabling the original garmin map and only enabling the osm one.

Hopefully that simple case will work, and it will make it easyer to understand what is wrong when you add steps like topo maps, multiple active maps, self-made maps, fancy mapsource functionality, etc.

permanent link

answered 14 Jan '13, 10:38

Vincent%20de%20Phily's gravatar image

Vincent de P... ♦
17.0k16147244
accept rate: 19%

UPDATE: I called Garmin tech support 800-800-1020 and explained the issue. He asked me if I had any stored tracks or way points and I told him that, as a matter of fact, there were some "left over" tracks I saw on Basecamp that must have been from the previous owner. After determining that I didn't need them, he had me do a system reset by holding ENTER and PAGE keys (with the device powered off) while powering on. This clears any tracks or way points so back them up before resetting if you need them. Once reset and cleared I had highways and streets! Don't understand what exactly was wrong, but things are "back to normal" for the first time! Lol.

permanent link

answered 17 Jan '13, 17:00

aj_chicago's gravatar image

aj_chicago
41112
accept rate: 0%

I have a Vista HCX which in the menus as set-up/map/set-up/detail as a choice of most,more,normal,less or least perhaps there is a similar choice on your garmin and "most" may solve the problem.

permanent link

answered 14 Jan '13, 00:11

andy%20mackey's gravatar image

andy mackey
11.8k74126260
accept rate: 4%

1

I did find the same DETAIL option and set it to MOST. Still no streets, roads, topo. Thanks.

(14 Jan '13, 03:02) aj_chicago
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×290
×26
×21
×5
×4

question asked: 13 Jan '13, 22:57

question was seen: 11,290 times

last updated: 17 Jan '13, 17:00

powered by OSQA