I just followed instruction from http://switch2osm.org/serving-tiles/building-a-tile-server-from-packages/ on my virtual machine. I tried 3 times, using different countries from http://download.geofabrik.de/openstreetmap/ and couldn't get my local tiles generated, browsing to http://localhost/osm/slippymap.html.

I also tried this instructions: http://switch2osm.org/serving-tiles/manually-building-a-tile-server-12-04. However I ended up with the same result.

Are those manuals still viable?

EDIT: I tried on Ubuntu 12.04.1 32-bit

EDIT2: Solved. I will update this post soon after I verify installation/fixing steps again. Seems like libapache2-mod-tile tries to load data from outdated link, getting 404 error and hence making mapnik/renderd unable to render a tile.

EDIT3: OK. So the problem was when I install libapache2-mod-tile, it tries to load ne_10m_populated_places and 110m_admin_0_boundary_lines_land from http://www.naturalearthdata.com and fails to do so:

--2013-01-11 15:07:10--  http://www.naturalearthdata.com/http//www.naturalearthdata.com/download/10m/cultural/10m-populated-places.zip
Resolving www.naturalearthdata.com (www.naturalearthdata.com)... 66.147.242.194
Connecting to www.naturalearthdata.com (www.naturalearthdata.com)|66.147.242.194|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2013-01-11 15:07:12 ERROR 404: Not Found.

--2013-01-11 15:07:12--  http://www.naturalearthdata.com/http//www.naturalearthdata.com/download/110m/cultural/110m-admin-0-boundary-lines.zip
Resolving www.naturalearthdata.com (www.naturalearthdata.com)... 66.147.242.194
Connecting to www.naturalearthdata.com (www.naturalearthdata.com)|66.147.242.194|:80... connected.
HTTP request sent, awaiting response... 404 Not Found
2013-01-11 15:07:13 ERROR 404: Not Found.

So I kept getting this error in /var/log/syslog from renderd:

An error occurred while loading the map layer 'default': Shape Plugin: shapefile '/us
r/share/mapnik-osm-data/world_boundaries/110m_admin_0_boundary_lines_land.shp' does not exist (encountered during parsing of layer 'ne
countries' in map '/etc/mapnik-osm-data/osm.xml')

I am not sure whether it is my own issue since it may get blocked by my company firewall (although error message must be different), so it would've been nice if someone could double check it.

I solved it by manually downloading those archives from links provided by: http://wiki.openstreetmap.org/wiki/Mapnik
(those are: ne_10m_populated_places.zip and ne_110m_admin_0_boundary_lines_land.zip on that wiki page). Then I extracted them and copied .dbf, .prj, .shp, .shx files to /usr/share/mapnik-osm-data/world_boundaries. And I had to rename ne_110m_admin_0_boundary_lines_land to 110m_admin_0_boundary_lines_land, removing ne_ prefix from them.

After that I restarted renderd by:

sudo /etc/init.d/renderd restart

I guess the problem is caused by invalid link during installation of libapache2-mod-tile: http://www.naturalearthdata.com/http//www.naturalearthdata.com/download/10m/cultural

PS sorry for using "code" tags in inappropriate places. Parser kept "eating" my underscore symbols.

asked 11 Jan '13, 04:27

ashagi's gravatar image

ashagi
31114
accept rate: 0%

edited 11 Jan '13, 10:32

Did you complete the installation instructions without encountering any error messages?

(11 Jan '13, 06:56) Frederik Ramm ♦

Yes, please let us know what the problem was, so that we can get the instructions updated.

(11 Jan '13, 09:46) SomeoneElse ♦
1

Looks like someone else had this problem on #osm irc channel on 27th November, and the wiki page was updated since - http://wiki.openstreetmap.org/wiki/Talk:Mapnik#Download_required_data was added in late December. It looks like the libapache2-mod-tile package may need repackaging.

(11 Jan '13, 10:46) EdLoach ♦
Be the first one to answer this question!
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×9

question asked: 11 Jan '13, 04:27

question was seen: 3,769 times

last updated: 11 Jan '13, 10:46

powered by OSQA