0
1

I am trying to map an area from a GPX 1.1 file I collected on a trip (cannot easily return there). The GPX file was generated with OSMTracker for Android™ and contains both <wpt> and <trk>/<trkpt> tags.

My <wpt> points contain text descriptions (<name> tags) of map features such as barriers and roads. Unfortunately the current JOSM doesn't seem to display them in any meaningful way, and all the menu items I can find for the resulting "marker" layer are focused on Audio mapping, which is just so irrelevant.

My searching came up with references to a setting named "Create non-audio markers when reading GPX", but I was unable to find this setting in the actual JOSM user interface. I also came across a lot of (bad) replies about how to set icons for imported Garmin GPX files with <sym> tags, but that is not what I have, just a bunch of plain <name> tags.

I have also tried converting the other GPX layer to a data layer, but it only includes the nameless <trkpt> nodes, not the named <wpt> nodes.

So what is the practical way to import GPX data to JOSM for use as the base of mapping features?

asked 16 Nov '12, 04:13

jbohmdk's gravatar image

jbohmdk
26114
accept rate: 0%

If you would provide the file in question, I'd like to have a look at it. If you don't know how, put it to a one-klick-hoster like this one: http://ompldr.org/

(18 Nov '12, 17:18) malenki
1

I'm using GPX OSMTracker for Android along with JOSM (v5576). I'm able to see the way points in JOSM.

The text way point from the gpx file looks as follows :

    < wpt lat="12.88459012" lon="77.58261194">
        < ele>846.7< /ele>
        < time>2012-11-17T12:43:28Z < /time>
        < name><![CDATA[bus stop]]>< /name>
        < sat>9</sat>
    < /wpt>

Please ignore the spaces after the "<" symbol, there are adde to make the XML visible. Did you try turning off the imagery or changing the colors of GPS points (Preferences -> Display Settings -> Colors)?

(19 Nov '12, 04:38) BlueTiger
1

For info, a couple of related questions - here and here.

(30 Jan '13, 12:30) SomeoneElse ♦

First, sorry for not returning to this forum sooner.

I found my own workaround before any answers came here, this is extremely clumsy, but seemed the only way I could see the waypoints and their names in JOSM:

  1. Convert the gpx file from LF to CRLF format with cygwin (only needed on Windows).
  2. Use a text editor to create two copies of the file, one with waypoints only, one with trackpoints only.
  3. Use GPSBabel to convert the wpt-only gpx file to an osm file.
  4. In JOSM, import the waypoint osm file and the trackpoint gpx file as their own layers.
  5. Now do the actual editing.

I don't know why it worked for BlueTiger, as my waypoints look the same in the GPX and I was using the same JOSM version at the time. If this was about color settings, then the defaults must have been wrong in that version of JOSM.

As for the two links provided by user SomeOneElse, the first was another Garmin-gpx-symbol post of no relevance, but the other was very similar to both my problems and solutions, except I cared about all the waypoints in the file, not just one.

I don't think I was using any satellite image overlays during the editing. So I cannot accept Glassman's "answer" as having any relevance.

I cannot retest right now as I don't have a working Java on the PC.

Here are some snippets from one of the (large) files in question:

< ?xml version="1.0" encoding="UTF-8" ?>
< gpx xmlns="http://www.topografix.com/GPX/1/1" version="1.1" creator="OSMTracker for Android™ - http://osmtracker-android.googlecode.com/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="http://www.topografix.com/GPX/1/1 http://www.topografix.com/GPX/1/1/gpx.xsd ">
    < wpt lat="55.41190083600891" lon="11.560011318167248">
        < ele>87.0< /ele>
        < time>2012-10-28T23:24:29Z< /time>
        < name>< ![CDATA[School]]>< /name>
        < cmt>< ![CDATA[Accuracy: 5.0m]]>< /cmt>
        < sat>7< /sat>
        < hdop>1.25< /hdop>
    < /wpt>
...
    < trk>
        < name>< ![CDATA[Tracked with OSMTracker for Android™]]>< /name>
        < cmt>< ![CDATA[Warning: HDOP values aren't the HDOP as returned by the GPS device. They're approximated from the location accuracy in meters.]]>< /cmt>
        < trkseg>
            < trkpt lat="55.411865588216614" lon="11.560238205932786">
                < ele>70.0< /ele>
                < time>2012-10-28T23:24:02Z< /time>
                < hdop>8.75< /hdop>
            < /trkpt>
...
        < /trkseg>
    < /trk>
< /gpx>
permanent link

answered 03 Feb '13, 07:07

jbohmdk's gravatar image

jbohmdk
26114
accept rate: 0%

Try turning your background image (bing) off. You can also change the color of the gpx trace in Preferences. The light gray is really hard to read. So in Display Preferences, Colors Tab change gps marker to a brighter color. What is displayed is controlled in the GPS Tab. Look for Waypoint labeling.

permanent link

answered 31 Jan '13, 01:20

Glassman's gravatar image

Glassman
111
accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×521
×224
×71
×30

question asked: 16 Nov '12, 04:13

question was seen: 6,761 times

last updated: 03 Feb '13, 07:07

powered by OSQA