Hi there,

I'm hitting my head off a wall! I Have installed renderd and mapnik on Debain squeeze v6.0.5. Renderd(version 0.7.1) is starting without error. But when I request the /osm_tiles2/0/0/0.png . The server times out would not found and the console no map for: default

and google is no help :(

Huge Thanks

asked 17 Oct '12, 17:13

Dominc's gravatar image

Dominc
31336
accept rate: 0%

same problem here.

any news?

thanks.

(04 Jun '14, 19:59) vlasvlasvlas

Sounds like you just installed map rendering software (renderd + mapnik), but didn't get any geodata nor defined any map styles. But your question is a bit short on details to really help you.

Have you read a decent tutorial on how to make maps with Openstreetmap data? E.g. http://switch2osm.org/serving-tiles/

permanent link

answered 04 Jun '14, 20:52

cartinus's gravatar image

cartinus
7.0k964105
accept rate: 27%

Hi! thanks!!

I have all the tables mounted on local postgis.

here's my renderd.conf:

[renderd]
;socketname=/var/run/renderd/renderd.sock
num_threads=4
tile_dir=/var/lib/mod_tile
stats_file=/var/run/renderd/renderd.stats

;[renderd01]
;iphostname=::1
;ipport=7654
;num_threads=4
;tile_dir=rados://tiles/etc/ceph/ceph.conf
;stats_file=/var/run/renderd/renderd.stats

;[renderd02]
;iphostname=::1
;ipport=7654
;num_threads=8
;tile_dir=memcached://
;stats_file=/var/run/renderd/renderd.stats

[mapnik]
;plugins_dir=/usr/lib/mapnik/input
plugins_dir=/usr/local/lib/mapnik/input
font_dir=/usr/share/fonts/truetype
font_dir_recurse=1

[default]
URI=/osm_tiles/
TILEDIR=/var/lib/mod_tile
;XML=/home/jburgess/osm/svn.openstreetmap.org/applications/rendering/mapnik/osm-local.xml
XML=/opt/mapnik-style/osm.xml
HOST=10.10.10.232
TILESIZE=256
;HTCPHOST=proxy.openstreetmap.org
;** config options used by mod_tile, but not renderd **
;MINZOOM=0
;MAXZOOM=18
;TYPE=png image/png
;DESCRIPTION=This is a description of the tile layer used in the tile json request
;ATTRIBUTION=&copy;<a href=\"http://www.openstreetmap.org/\">OpenStreetMap</a> and <a href=\"http://wiki.openstreetmap.org/wiki/Contributors\">contributors</a>, <a href=\"http://opendatacommons.org/licenses/odbl/\">ODbL</a>
;SERVER_ALIAS=http://localhost/
;CORS=http://www.openstreetmap.org
;ASPECTX=1
;ASPECTY=1

;[style2]
;URI=/osm_tiles2/
;TILEDIR=rados://tiles/etc/ceph/ceph.conf
;TILESIZE=512
;XML=/home/jburgess/osm/svn.openstreetmap.org/applications/rendering/mapnik/osm-local2.xml
;HOST=tile.openstreetmap.org
;HTCPHOST=proxy.openstreetmap.org
;** config options used by mod_tile, but not renderd **
;MINZOOM=0
;MAXZOOM=22
;TYPE=png image/png
;DESCRIPTION=This is a description of the tile layer used in the tile json request
;ATTRIBUTION=&copy;<a href=\"http://www.openstreetmap.org/\">OpenStreetMap</a> and <a href=\"http://wiki.openstreetmap.org/wiki/Contributors\">contributors</a>, <a href=\"http://opendatacommons.org/licenses/odbl/\">ODbL</a>
;SERVER_ALIAS=http://localhost/
;CORS=*

And here's what renderd terminal told me:

root@host:/# sudo -u www-data renderd -f -c /etc/renderd.conf

sudo: unable to resolve host sig-desarrollo2
renderd[30155]: Rendering daemon started
renderd[30155]: Initiating reqyest_queue
iniparser: syntax error in /etc/renderd.conf (7):
-> ;[renderd01]
iniparser: syntax error in /etc/renderd.conf (14):
-> ;[renderd02]
iniparser: syntax error in /etc/renderd.conf (35):
-> ;** config options used by mod_tile, but not renderd **
iniparser: syntax error in /etc/renderd.conf (46):
-> ;[style2]
iniparser: syntax error in /etc/renderd.conf (53):
-> ;** config options used by mod_tile, but not renderd **
renderd[30155]: Parsing section renderd
renderd[30155]: Parsing render section 0
renderd[30155]: Parsing section mapnik
renderd[30155]: Parsing section default
renderd[30155]: config renderd: unix socketname=/var/run/renderd/renderd.sock
renderd[30155]: config renderd: num_threads=4
renderd[30155]: config renderd: num_slaves=0
renderd[30155]: config renderd: tile_dir=/var/lib/mod_tile
renderd[30155]: config renderd: stats_file=/var/run/renderd/renderd.stats
renderd[30155]: config mapnik:  plugins_dir=/usr/local/lib/mapnik/input
renderd[30155]: config mapnik:  font_dir=/usr/share/fonts/truetype
renderd[30155]: config mapnik:  font_dir_recurse=1
renderd[30155]: config renderd(0): Active
renderd[30155]: config renderd(0): unix socketname=/var/run/renderd/renderd.sock
renderd[30155]: config renderd(0): num_threads=4
renderd[30155]: config renderd(0): tile_dir=/var/lib/mod_tile
renderd[30155]: config renderd(0): stats_file=/var/run/renderd/renderd.stats
renderd[30155]: config map 0:   name(default) file(/opt/mapnik-style/osm.xml) uri(/osm_tiles/) htcp() host(10.10.10.232)
renderd[30155]: Initialising unix server socket on /var/run/renderd/renderd.sock
renderd[30155]: Created server socket 4
renderd[30155]: Renderd is using mapnik version 2.0.3
renderd[30155]: DEBUG: Loading font: /usr/share/fonts/truetype/unifont/unifont.ttf
renderd[30155]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSerif-Italic.ttf
renderd[30155]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSans.ttf
renderd[30155]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSansMono-Oblique.ttf
renderd[30155]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSansMono-Bold.ttf
renderd[30155]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSerifCondensed-Bold.ttf
renderd[30155]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSerifCondensed-BoldItalic.ttf
renderd[30155]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSansCondensed.ttf
renderd[30155]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSans-ExtraLight.ttf
renderd[30155]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSansCondensed-BoldOblique.ttf
renderd[30155]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSans-Oblique.ttf
renderd[30155]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSerifCondensed-Italic.ttf
renderd[30155]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSerif-Bold.ttf
renderd[30155]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSerifCondensed.ttf
renderd[30155]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSansMono.ttf
renderd[30155]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSerif-BoldItalic.ttf
renderd[30155]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSerif.ttf
renderd[30155]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSansCondensed-Bold.ttf
renderd[30155]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSansMono-BoldOblique.ttf
renderd[30155]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSansCondensed-Oblique.ttf
renderd[30155]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSans-BoldOblique.ttf
renderd[30155]: DEBUG: Loading font: /usr/share/fonts/truetype/ttf-dejavu/DejaVuSans-Bold.ttf
Running in foreground mode...
renderd[30155]: Starting stats thread
debug: init_storage_backend: initialising file storage backend at: /var/lib/mod_tile
renderd[30155]: Loading parameterization function for 
debug: init_storage_backend: initialising file storage backend at: /var/lib/mod_tile
renderd[30155]: Loading parameterization function for 
debug: init_storage_backend: initialising file storage backend at: /var/lib/mod_tile
debug: init_storage_backend: initialising file storage backend at: /var/lib/mod_tile
renderd[30155]: Loading parameterization function for 
renderd[30155]: Loading parameterization function for 
renderd[30155]: Using web mercator projection settings
renderd[30155]: Using web mercator projection settings
renderd[30155]: Using web mercator projection settings
renderd[30155]: Using web mercator projection settings
renderd[30155]: DEBUG: Got incoming connection, fd 11, number 1
renderd[30155]: DEBUG: Got incoming request with protocol version 2
renderd[30155]: DEBUG: Got command RenderPrio fd(11) xml(Default), z(10), x(533), y(357), mime(image/png), options()
renderd[30155]: No map for: Default
renderd[30155]: DEBUG: Failed to read cmd on fd 11
renderd[30155]: DEBUG: Connection 0, fd 11 closed, now 0 left
(04 Jun '14, 20:58) vlasvlasvlas

i'm calling inside renderd.conf default osm.xml

do i _HAVE to run ./generate_xml.py to make my own osm-local.xml?

i'm using default osm.xml

(04 Jun '14, 21:01) vlasvlasvlas

anyone ? txs!

(05 Jun '14, 15:33) vlasvlasvlas

I realize this is an old question, but I am posting what worked for me in the hopes someone else doesn't waste time hunting down this stupid problem. I was getting the error "No map for: Default".

Look in your apache configuration file and make sure that your AddTileConfig has "default" properly capitalized. That is, make sure your file looks something like:

AddTileConfig /osm-tiles/ default

Notice the lower case "d" in default. The example I pulled from somewhere had the "d" capitalized. Renderd fails on a string compare when it compares "Default" to "default".

permanent link

answered 15 Jun '15, 21:50

sjkii's gravatar image

sjkii
11
accept rate: 0%

edited 15 Jun '15, 21:53

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×524
×309
×258
×77
×26

question asked: 17 Oct '12, 17:13

question was seen: 6,946 times

last updated: 15 Jun '15, 21:53

powered by OSQA