I keep getting a Potlatch 2 error right now and it is a huge pain because I do a huge update then it doesn't save

After pressing Save and waiting for a while, I get: Couldn't upload data: 0 Error #2032

Any ideas or is this a known bug.. ;( Back to JOSM/original potlatch I guess..

asked 02 Dec '10, 02:24

wbski's gravatar image

wbski
1466914
accept rate: 50%

edited 02 Dec '10, 10:33

Andy%20Allan's gravatar image

Andy Allan
11.8k23121144

All I did to generate the error was remove a duplicate road and then save the changeset.

(07 Dec '10, 18:29) rickasselin

At present there's a bug where, if you delete a way where part of it is off-screen, then save, this will throw an error. We're trying to fix this urgently but it may require an API change.

(08 Dec '10, 00:14) Richard ♦

I also removed some ways in Pot2, and now also got me this error. I'm waiting for a solution with the browser open.

(08 Dec '10, 16:22) gdonadel

I just got the error by dragging a viewpoint icon onto the map and clicking save.

(08 Dec '10, 17:45) discus277

Now able to drag icons onto map and save successfully

(08 Dec '10, 19:08) discus277

I just got the error as well with a moderate size update. Editing existing paths, adding new paths with connections, drag dropping viewpoint icons, and changing name of polygon layer. Leaving browser open till advice, I don't want to loose all the updates...

I may have deleted some ways that had nodes off screen. Any idea on when this may be fixed? I know it is probably a pain to fix given that it is a server API issue from what I read, but it would be very helpful.

(10 Dec '10, 00:38) sblanc

This is incredibly frustrating when you've spent a long time working on a change.

(15 Dec '10, 17:24) fluteflute
showing 5 of 7 show 2 more comments

This is what happens when the server refuses to process the upload. There are a few ways that this can be caused, and we've been working on tracking them down, but flash player doesn't pass on the responses when there's an error so it's quite hard for P2 to handle properly.

The most common one is to try deleting a road which leads off the edge of your screen - you should check the whole length before deleting the road.

Some of the potential solutions we've come up with require server-side changes too, so things are still in progress and are being developed.

Please note that this is not the place to post "I'm having this problem too", especially in the box below that says "Your Answer" - only respond below if you have a better answer to the original problem than this answer.

permanent link

answered 02 Dec '10, 10:33

Andy%20Allan's gravatar image

Andy Allan
11.8k23121144
accept rate: 30%

edited 13 Dec '10, 09:46

I've just managed to get round this error for the first time.‡ :)

I tried saving from Potlatch 2 and got the dreaded "Couldn't upload data: 0 Error #2032". I tried re-saving a couple of times but got the same error.

However, I then pressed 'C', which is supposed to 'close' a changeset. It gave me an error to the effect that it couldn't close the changeset, but guess what? When I tried to save again, it went through. My changes were saved successfully and have been rendered in Mapnik already.

Hope this workaround helps others, but I really hope this bug gets squashed a.s.a.p.


‡ Very glad of it too, because not only have I just spent 45 minutes editing without saving, I've also been deleting the waypoints from my GPS as I entered them all into Potlatch, so I'd have been really annoyed if I'd lost all the surveying time as well.

permanent link

answered 02 Feb '11, 21:12

Tim%20Morley's gravatar image

Tim Morley
11633
accept rate: 33%

We can't fix the bug without knowing what triggers it. If you can provide consistent steps to reproduce it (or even a hint as to what might cause it), that's great. But otherwise there's really not much that we can do. It's not a bug I've ever encountered.

Please please please don't leave it 45 minutes between saves. Potlatch 2 is a very young yet very complex piece of software. There are inevitably going to be bugs. Please save every five minutes at least.

(02 Feb '11, 22:06) Richard ♦
1

"If you can provide consistent steps to reproduce it (or even a hint as to what might cause it), that's great." <— no idea at this stage I'm afraid, but I'll have a poke around and see if I can reproduce it.

"Please please please don't leave it 45 minutes between saves." <— that's exactly the advice that I give out to friends and family all the time. ;-) OK, I'll try and remember!

(02 Feb '11, 22:17) Tim Morley
1

If I were to guess (and this really is a complete guess) I'd say that the most likely place to look for something like this is in the undo, redo and cancel behaviour. Certainly, when observing Potlatch users before, I've noticed that they might use undo and cancel in very different ways to the way I'm used to; and undo is a complex operation at any rate.

(02 Feb '11, 22:58) Richard ♦
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×207
×38

question asked: 02 Dec '10, 02:24

question was seen: 3,945 times

last updated: 02 Feb '11, 22:58

powered by OSQA