I have a Nuvi 500 and I am trying to use OSM maps that are on a micro SD card (2GB).On the SD card,I made a folder "Garmin." Then I copied a "gmapsupp.img" file (619,264 KB) inside the Garmin folder.Then I went to tools,settings,map,map info on the Nuvi.2 maps are selected.OSM generic routable (I think this is the one I just put on the SD card.) And OSM map (1) OSM World Routable (63241144), OSM World ... I think this is a map that someone installed for me 2 years ago.It is a basic map with main roads.I am going to Europe Monday and need more detailed maps.When I zoom into Barcelona,I only see 2 or 3 roads. In my Nuvi built in memory,in the Garmin folder,are about 25 files.Below I am listing some of the larger ones.

gmapsupp.img      58,608 KB
gmapsupp.img.img      28,316 KB
gmapprom1.img        899,984 KB
gmapprom.img       1,106,432 KB
gmapbmap.img          49,824 KB
GUPDATE.GCD            8,987 KB
Ecuador gmapsupp.img   5,026 KB

This is one I probably tried to install 2 years ago while in South America.I didn't work-just had the world map detail.

I just don't know what I'm doing wrong.I've read directions several places and nothing has worked.Hopefully someone can see my error and help me.Thanks.

asked 30 Aug '12, 15:35

doogle's gravatar image

doogle
6223
accept rate: 0%

edited 30 Aug '12, 15:56

scai's gravatar image

scai ♦
31.1k18281434


I'm guessing that you've confused it by giving it more than one gmapsupp.img **. Before doing anything else though - TAKE A BACKUP! (so that if you delete anything that you shouldn't have, you can restore it).

If it helps, here's what's in the "Garmin" directory on the main memory of my Nuvi:

      23879 08-14 18:47 GarminDevice.xml
          0 08-14 18:47 GPX
          0 2010-05-17  Diag
          0 2010-04-14  Voice
      65901 2010-02-28  Locales.xml
   51654656 2009-12-21  gmapbmap.img
     605184 2009-11-30  gmaptz.img
         14 2009-05-26  fs_image.ver
 1715634176 2009-03-18  gmapprom.img
      25214 2007-09-12  nuvi_drive.ico
          0 1979-12-31  ExtData
          0 1979-12-31  Vehicle
          0 1979-12-31  Text
          0 1979-12-31  Help
          0 1979-12-31  POI
          0 1979-12-31  JPEG
          0 1979-12-31  RemoteSW
          4 1970-01-01  gmapbmap.sum
          4 1970-01-01  gmaptz.sum
          4 1970-01-01  gmapprom.sum
          0 1970-01-01  EULA

And here's what's on the "Garmin" directory on the SD Card:

 343482368 2012-01-05  gmapsupp.img
     10695 2012-01-05  osmmap.tdb
      7168 2012-01-05  osmmap.img

I believe that the "Ecuador gmapsupp.img", "gmapsupp.img" and "gmapsupp.img.img" that you have in the main memory are the ones that you want to get rid of. I don't know what "gmapprom1.img" is, so I wouldn't delete that (although I suspect it might be a from-Garmin update to ther map).

** Newer Garmin models do support multiple supplementary maps I believe - but I doubt yours does.

permanent link

answered 30 Aug '12, 17:02

SomeoneElse's gravatar image

SomeoneElse ♦
32.0k63330748
accept rate: 15%

I deleted the "Ecuador gmapsupp.img and the "gmapsupp.img.img". Nothing seems any different.

My SD card has gmapsupp.img in the Garmin file.Nothing else-unlike yours.

(30 Aug '12, 20:42) doogle
1

The osmmap.tdb and osmmap.img are optional - you don't need those.

Have you still got a gmapsupp.img in the device memory AND on the SD card? If so, you shouldn't have.

(30 Aug '12, 21:16) SomeoneElse ♦

I deleted the gmapsupp.img on the Garmin memory.After doing that,my OSM World Routable selection is missing in "map info".But the maps in Europe seem to be the same as before-basic.

I took my SD card out,and Europe still looks the same.The OSM routable isn't in the "map info" anymore.

(31 Aug '12, 03:57) doogle
2

I have maps on my GPS now.I downloaded the maps again-same files.And now they work.The only other thing that is different is that I used a different program to unzip. Quick Zip. I'm a happy traveler again.

(31 Aug '12, 05:14) doogle

I've been using a recent talkytoaster OSM GB map on a Nuvi 2460LMT for the last couple of weeks. Seems to be going OK for routing using imported destinations other than a couple of mapping errors - now corrected..

Today I drove home without setting destination and many minor roads didn't show at all - arrow on empty screen but road names were shown at the top. I've not taken much notice of roads underlying routes but there may be an issue here.

Do you have map detail set appropriately?

permanent link

answered 30 Aug '12, 17:03

fruit-uk's gravatar image

fruit-uk
141239
accept rate: 25%

I've seen the "minor roads don't show" effect, but think that it's a different issue to what the questioner reported.

If you're following a Nuvi down a long minor road it will tend not to show the minor road network around where you are unless you zoom in. I suspect that what's happening is that the standard maps from Garmin will tend to have much less detail than OSM-generated maps (although it depends on how you setup mkgmap, of course) and therefore the "zoomed out overview" makes sense in that context.

(30 Aug '12, 17:39) SomeoneElse ♦
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×419
×28
×19

question asked: 30 Aug '12, 15:35

question was seen: 4,958 times

last updated: 31 Aug '12, 05:14

powered by OSQA