NOTICE: is no longer in use from 1st March 2024. Please use the OpenStreetMap Community Forum

Hi dear community - I am new here and I use a older version (1.02) of "BeeLineGPS". After the first test with this tracking software I get a logfile like this :

$GPGSA,A,3,15,18,17,09,12,27,,,,,,,2.4,1.6,1.83E $GPRMC,074917.000,A,4905.3612,N,00924.2183,E,0.00,,290812,,,A75
$GPGSA,A,3,15,09,12,27,,,,,,,,,2.5,2.2,1.03F $GPRMC,082444.000,A,4905.4403,N,00924.2823,E,1.08,114.07,290812,,,A65

As I would like to use this older registered software, I would like to know, how to convert this file to a up loadable format used by open street map.

At the moment I don´t want to spend money without knowing more about this subject. Are they any converters to solve the problem?

Thanks & Regards Yougy2

asked 29 Aug '12, 11:00

Yougy2's gravatar image

accept rate: 0%

edited 29 Aug '12, 19:27

SimonPoole's gravatar image

SimonPoole ♦

Thank you both for the quick answer ! Have downloaded gpsbabel and looked up the setup.

Have located GPX XML (gpx) and NMEA 0183 sentences (nmea) Hope this have been the correct selection. Left all to default.

Input file has been a txt-file as copied off the GPS Unit Output NMEA 0183 sentences (nmea)

Used gpsbabel to get the following msg.:

gpsbabel -w -t -i nmea,gprmc=0,gpgga=0,gpvtg=0,gpgsa=0,get_posn=0,append_positioning=0,gisteq=0 -f C:\Users\Spiess\Desktop\new file.txt -o nmea,gprmc=0,gpgga=0,gpvtg=0,gpgsa=0,get_posn=0,append_positioning=0,gisteq=0 -F "C:\Users\Spiess\Desktop\newgpx file
nmea cannot open '"C:\Users\Spiess\Desktop\newgpx file' for write.  Error was 'Invalid argument'.

Any ideas? There was an Error executing gpsbabel, Proccess ended with Error 1.

Regards & Thanks Yougy2

(29 Aug '12, 13:07) Yougy2

It looks like you've got spaces in file names, but haven't quoted the file name. Instead of using:

new file.txt


"new file.txt"

or perhaps better:


(29 Aug '12, 13:13) SomeoneElse ♦

Hi, Thanks ... Have done the changes - File for Input now -- "C:UsersmeDesktopnewfile.txt" NMEA 0183 sentences (nmea)

Unchanged Optios: gprmc=0,gpgga=0,gpvtg=0,gpgsa=0,get_posn=0,append_positioning=0,gisteq=0

File for output, unchanged -- "C:meSpiessDesktopnewgpx file GPX XML

Unchanged options: suppresswhite=0,logpoint=0,humminbirdextensions=0,garminextensions=0

Error : gpsbabel -w -t -i nmea,gprmc=0,gpgga=0,gpvtg=0,gpgsa=0,get_posn=0,append_positioning=0,gisteq=0 -f "C:UsersmeDesktopnewfile.txt" -o gpx,suppresswhite=0,logpoint=0,humminbirdextensions=0,garminextensions=0 -F "C:UsersmeDesktopnewgpx file nmea: Cannot open file '"C:UsersmeDesktopnewfile.txt"'!

Error executing gpsbabel: Prozess end with code 1

Any other ideas ? Thanks, Regards Yougy2

(29 Aug '12, 13:27) Yougy2

Just have seen there is a option to send a screen shot. Ad this now to the question / reply sent already.

alt text

Hope this works - I am a New User here ...

Thanks & Regards Yougy2

(29 Aug '12, 13:38) Yougy2

Dear Community, as stated, the converted "Example.gpx" has been uploaded. At least visible entry in "mytracks". The map seems to be the right area, but I am unable to identify my uploaded track.

Enclose the file details -

Dateiname: Example.gpx (herunterladen) Hochgeladen am: 31. August 2012 um 10:10 Punkte: 2,004 Startkoordinate: 49.0894; 9.40364 (Karte / bearbeiten) Besitzer: Yougy2 Beschreibung: Ein Test einer Fahrstrecke - Erstuser Tags: Keine Sichtbarkeit: Identifizierbar (wird in der Trackliste als sortierte Punktfolge mit Zeitstempel angezeigt)

How I am able to identify this track ? Potlach is just showing loads of tracks, without any chance identifying my own to check or work on it.

Thanks for the help and support Yougy2

(31 Aug '12, 11:54) Yougy2

In Potlatch2 at the top click on GPS, My Tracks, Refresh list, then click on the track you are editing from.

(31 Aug '12, 12:43) andy mackey

Thank you found a very faint colored tack, only visible, when no other tacks are next to it. Deleted it again to do a better one.

Is there a off-line software to be used ? And how I get my uploaded track better visible to work on it ?

Thanks, Regards Yougy2

(31 Aug '12, 12:58) Yougy2

software to do what? Ideally, as your original question as been answered you should accept the answer you think best, award points where earned. then ask a new clear separate question. So that users can search questions easily and quickly go the the best answer.

(31 Aug '12, 13:15) andy mackey

I'm sure that you're already aware, but just in case you are not - you'll need to edit the map to reflect the trace that you've uploaded - an uploaded GPS trace doesn't magically become a cycleway, for example. There's an introductory series of pages on the wiki here (und auf Deutsch).

(31 Aug '12, 13:56) SomeoneElse ♦

Thank you for all the Support to all here !! Was grate !! Managed to upload an locating the Track on screen. The problem was, that the upload track gets displayed in some sort light blue. Difficult to see on a laptop.

Thanks Yougy2

(31 Aug '12, 18:50) Yougy2

I must admit that until I messed around with screen brightness and put on spectacles I found the light blue less than ideal.

(31 Aug '12, 22:22) andy mackey

If you select "Map Style" (at the top right) you might find that one of the other options (besides the default "Potlatch") might contrast better with the light blue. There isn't a built-in map style that uses something other than light blue for GPS traces, though.

(31 Aug '12, 22:38) SomeoneElse ♦
showing 5 of 12 show 7 more comments

That looks like NMEA format to me. Since NMEA and GPX are both widely supported standards, almost any computer mapping or GPS application will probably be able to import a file in NMEA format and export the data in GPX format. If you don't have any such application already installed, try Andy Mackey's suggestion.

permanent link

answered 29 Aug '12, 12:33

Madryn's gravatar image

accept rate: 13%

This worked for me:

gpsbabel -i nmea -f "C:Example.nmea" -o gpx -F "C:Example.gpx".

The file that I had re-named as C:Example was a NMEA file downloaded from the internet. I would have used your example, but it seems to have shrunk. The GPX file that gpsbabel created was successfully opened and plotted by two other applications, including MapSource, which I have found to be rather unwilling to accept GPX files containing errors.

Once you have got that working, you could try adding the command line options one by one, but you probably don't need them. If you just want to upload the file to OSM, any GPX file should suffice.

permanent link

answered 29 Aug '12, 17:59

Madryn's gravatar image

accept rate: 13%

Thanks for all the help !! Looks like some conversion has been done using a BAT File as suggested by Madryn. Hope I have done it correctly awarding some points ...

gpsbabel -i nmea -f "C:Example.nmea" -o gpx -F "C:Example.gpx".

helped changing it a little for my setup here. The input file created by the old version of BeeLineGPS is a TXT-File! This is why the conversion of GPS Babel did not worked. It´s silly I have not recognized this in the first place - sorry.

Have only converted the TXT to a GPX

TXT - File:

$GPGSA,A,3,15,18,17,09,12,27,,,,,,,2.4,1.6,1.83E $GPRMC,074917.000,A,4905.3612,N,00924.2183,E,0.00,,290812,,,A75 $GPGGA,074918.000,4905.3612,N,00924.2183,E,1,05,1.8,471.1,M,48.0,M,,000055 $GPGSA,A,3,15,18,17,12,27,,,,,,,,2.8,1.8,2.23C $GPRMC,074918.000,A,4905.3612,N,00924.2183,E,0.00,,290812,,,A7A $GPGGA,074919.000,4905.3612,N,00924.2183,E,1,06,1.6,471.1,M,48.0,M,,000059 $GPGSA,A,3,15,18,17,09,12,27,,,,,,,2.4,1.6,1.83E $GPRMC,074919.000,A,4905.3612,N,00924.2183,E,0.00,,290812,,,A7B $GPGGA,074920.000,4905.3612,N,00924.2183,E,1,04,9.1,471.1,M,48.0,M,,00005E $GPGSA,A,3,18,17,09,12,,,,,,,,,9.5,9.1,2.839 $GPGSV,3,1,12,09,84,023,24,27,75,090,16,31,59,297,,26,57,288,75 $GPGSV,3,2,12,12,50,241,33,16,49,236,,15,38,182,,17,33,055,2473 $GPGSV,3,3,12,22,17,300,33,18,12,255,33,30,10,242,,28,07,058,71 $GPRMC,074920.000,A,4905.3612,N,00924.2183,E,0.00,,290812,,,A71 $GPGGA,074921.000,4905.3612,N,00924.2183,E,1,06,1.6,471.1,M,48.0,M,,0000*52 .... .... looks now like :

<gpx version="1.0" creator="GPSBabel - &lt;a href=" http:="""="">" xmlns:xsi="" xmlns="" xsi:schemaLocation=" ">"> <time>2012-08-30T11:33:41Z</time> <bounds minlat="49.089228333" minlon="9.403351667" maxlat="49.090763333" maxlon="9.406095000"/> <trk> <trkseg> <trkpt lat="49.089353333" lon="9.403638333"> <time>2012-08-29T07:49:17Z</time> <course>0.000000</course> <speed>0.000000</speed> </trkpt> <trkpt lat="49.089353333" lon="9.403638333"> <ele>471.100000</ele> <time>2012-08-29T07:49:18Z</time> <course>0.000000</course> <speed>0.000000</speed> <fix>3d</fix> <sat>5</sat> <hdop>1.800000</hdop> <vdop>2.200000</vdop> <pdop>2.800000</pdop> </trkpt> <trkpt lat="49.089353333" lon="9.403638333"> <ele>471.100000</ele> <time>2012-08-29T07:49:19Z</time> <course>0.000000</course> <speed>0.000000</speed> <fix>3d</fix> <sat>6</sat> <hdop>1.600000</hdop> <vdop>1.800000</vdop> <pdop>2.400000</pdop> </trkpt> <trkpt lat="49.089353333" lon="9.403638333"> <ele>471.100000</ele> <time>2012-08-29T07:49:20Z</time> <course>0.000000</course> <speed>0.000000</speed> <fix>3d</fix> <sat>4</sat> <hdop>9.100000</hdop> <vdop>2.800000</vdop> <pdop>9.500000</pdop> </trkpt> <trkpt lat="49.089353333" lon="9.403638333"> <ele>471.100000</ele> <time>2012-08-29T07:49:21Z</time> <course>0.000000</course> <speed>0.000000</speed> <fix>3d</fix> <sat>6</sat> <hdop>1.600000</hdop> <vdop>1.800000</vdop> <pdop>2.400000</pdop> </trkpt> <trkpt lat="49.089353333" lon="9.403638333"> <ele>471.100000</ele> <time>2012-08-29T07:49:22Z</time> <course>0.000000</course> <speed>0.000000</speed> <fix>3d</fix> <sat>6</sat> <hdop>1.600000</hdop> <vdop>1.800000</vdop> <pdop>2.400000</pdop> </trkpt> <trkpt lat="49.089353333" lon="9.403638333"> <ele>471.100000</ele> <time>2012-08-29T07:49:23Z</time> <course>0.000000</course> <speed>0.000000</speed> <fix>3d</fix> ... ...

Now I Look into how to upload the file into openstreetmap to find out how I get further. Will wait a few days, in case I do something wrong trying this file "life".

Don´t want to do something silly or damage the system. So your checkup would be highly appreciated.

Now I read the suggested link

Thanks to all ...

(30 Aug '12, 12:56) Yougy2

You can award points, but it's also helpful to "mark this answer as accepted answer" so that the question appears as "answered" (which also awards 15 points).

(30 Aug '12, 13:15) SomeoneElse ♦

A GPX file has to start with a line something like

"<?xml version="1.0" encoding="UTF-8"?>"

Perhaps something went wrong when you copied the file here, because when I took your NMEA data and ran it through GPS Babel as described, it produced a valid GPX file, although obviously containing only a few points.

Try uploading the complete GPX file to OSM. It should be accepted, and I am sure that the OSM programmers have ensured that you cannot damage anything by making a simple mistake, such as uploading the wrong file. You can delete an uploaded trace from OSM if you don't like it.

(30 Aug '12, 22:25) Madryn
permanent link

answered 29 Aug '12, 12:25

andy%20mackey's gravatar image

andy mackey
accept rate: 4%

edited 29 Aug '12, 12:55

BeeLineGPS seems to be software, so what is the hardware are you using to record the trace in the first place it may be easier to use some other software directly in future if you can't convert it, unless you wish to convert some previously recorded beelinegps files that you have already.

(29 Aug '12, 12:46) andy mackey

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 29 Aug '12, 11:00

question was seen: 12,320 times

last updated: 31 Aug '12, 22:38

NOTICE: is no longer in use from 1st March 2024. Please use the OpenStreetMap Community Forum