I added 2 entrances with addresses to a building. One of them appears when I look at the map but not the other. I don't see any difference between them. Can someone tell me if I've done something wrong? Here is the link: http://www.openstreetmap.org/?lat=38.903014&lon=-77.038619&zoom=18&layers=M

The nodes I added are: 1840518774 (does not appear) and 1840535446 (does appear)

Thanks.

asked 02 Aug '12, 02:08

hleopold's gravatar image

hleopold
26112
accept rate: 0%


Mapnik - the rendering program that creates this map from your data - will drop names and house numbers if they would intersect with some other icon or label on the map. It is likely that Mapnik tries to avoid a visual conflict with the "Dress Barn Woman" label in this case.

I do not see any problem with your tagging. (Except maybe the use of abbreviations, but that has nothing to do with the issue at hand.)

permanent link

answered 02 Aug '12, 08:02

Tordanik's gravatar image

Tordanik
10.7k1294132
accept rate: 33%

It may be that the link road it is on is not named so although the node is addressed the street nearby is not. details node 1840518774 as addr num =1001 addrstreet= conneticut avenue but it is on a way = highway primary link but name is blank. where as the other node is on a named street that it can get tied to..maybe

permanent link

answered 02 Aug '12, 09:35

andy%20mackey's gravatar image

andy mackey
11.8k74126260
accept rate: 4%

edited 02 Aug '12, 10:32

1

How does this have an influence on Mapnik rendering? As far as I know, the only thing Mapnik cares about is addr:housenumber. Feel free to correct me, though.

(02 Aug '12, 09:51) Tordanik

I am not sure but node 1840518774 as addr num =1001 addrstreet= conneeticut avenue but it is on a way ='' highway primary link NO NAME where as the other node is on a named street that it can get tied to..maybe

(02 Aug '12, 10:17) andy mackey

Tordanik link to abbreviations is very important and a trap I have fell into e.g st & ave and do not get speliing wrong! but this more of a nominatim issue I guess

(02 Aug '12, 10:38) andy mackey
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×214
×160
×19

question asked: 02 Aug '12, 02:08

question was seen: 2,732 times

last updated: 02 Aug '12, 10:43

powered by OSQA