Hi, after the last download i miss the "landuse" colors on my Garmin nüvi. If i convert OSM-data for the Garmin devices the colors of the landuse and natural tags are gone away. one month bevore the colors are all correct, but now, all the area of wood or meadow are not shown on the Garmin. Please reactivate the tags for this nessesary things. for example: Madagascar, Nosy Be have a very detaild surface on OSM ( wood, farmland, mountains) but all this is goneaway after the convert for the Garmin Nüvi. greetings Roman

asked 21 Jun '12, 13:48

roki's gravatar image

roki
45457
accept rate: 0%

edited 21 Jun '12, 17:01

SomeoneElse's gravatar image

SomeoneElse ♦
32.0k63327747

1

How did you "convert" the map for your Garmin device or where did you download it?

(21 Jun '12, 14:01) scai ♦

Do you mean this Nosy Be?

(21 Jun '12, 14:09) SomeoneElse ♦

1: first i download it on raumbezug.eu. i covert it also by me self with mkgmap. both with the same problem. 2: yes this is the island. but also in switzerland and the hole world.......

(21 Jun '12, 16:35) roki

If you haven't changed the import process (i.e. you're running exactly the same mkgmap version in exactly the same way as before) then, as you suggest, the data must have changed.

I've looked at the centre of the area that you're interested in with Potlatch 1, and can't see any obvious recent deletions.

I've no idea where the raumbezug.eu site gets its data from, though. It's possible that they are filtering some features from the OSM data before it gets to you - that would explain things being missing. Unfortunately, that site looks broken currently - I see a page full of "Deprecated: Function split() is deprecated in /home/geolist/www/raumbezug.eu/parser/include/class.parser_file_phpcms.php on line 196" when I browse to it.

In order to find out what the problem is, I suggest that you identify one feature that's missing from your new maps that was present in your old ones. Have a look in the mkgmap style file to see what OSM tags were mapped to that feature, and have a look at the OSM map to make sure that it's definitely still there (zoom in and use "Browse Map Data" on the "Edit" menu). That should give you a node or (more probably) a way ID. You can then search (using grep) through the "old" and "new" input data for that way ID. If you need to convert a .PBF file to a .OSM file, you can use osmconvert for that. If you're on Windows and don't have "grep" available, you can get one from Unxutils here.

If it turns out that your current download site is filtering data that you don't want it to, then I'd suggest downloading a planet extract from elsewhere. I've found Geofabrik very reliable, but lots of other sites are available.

permanent link

answered 21 Jun '12, 16:58

SomeoneElse's gravatar image

SomeoneElse ♦
32.0k63327747
accept rate: 15%

thx for your help. i do not changed the import process, i have not update my mkgmap. the problem is still there. raumbezug.eu have a problem, but if you scroll down, you will see the corect page. if i convert be my self, i use the data from geofabrik... wih the same problem.

(21 Jun '12, 17:25) roki

ok, i found the problem in the new mkgmap. with the old versin is all ok, but if i convert with the new version the colours gone away. i try to change the options of mkgmap in the style file....

permanent link

answered 24 Jun '12, 15:09

roki's gravatar image

roki
45457
accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×287
×81
×23
×19

question asked: 21 Jun '12, 13:48

question was seen: 3,613 times

last updated: 24 Jun '12, 15:09

powered by OSQA