When I go to EDIT mode, I get an icon library in the left panel and an empty panel where the map should be. I tried with IE9 and FireFox 12, but the result is the same. Help ? PS: using Potlatch2. Tried it with PL1: I get a map, but it takes forever to load and another eternity to pan to another area.

asked 21 May '12, 22:20

Gilbert's gravatar image

Gilbert
41115
accept rate: 0%

edited 21 May '12, 22:30

1

Can you send a link to the area you are trying to edit, and say what zoom level you are trying to use to edit? It sounds like you are trying to edit an area where there is a lot of data which is taking some time to load.

(22 May '12, 08:26) EdLoach ♦
2

There is a related discussion at http://forum.openstreetmap.org/viewtopic.php?id=16229 : the OpenMapquest P2 editor works for some people.

(22 May '12, 12:03) Mike N
3

That's probably because MQ Open is using an old version. More recent versions pull in some code from the Adobe servers (to minimise the .swf filesize) and it appears to be this that's failing on some setups. We're investigating what to do about this. At present taking Adobe outside and shooting them seems like a convincing solution.

(22 May '12, 12:30) Richard ♦
1

Looked at the related discussion, and indeed, I get a map with PL2 in OpenMapQuest. Loading speed is variable, but the area I'm looking at has lots of little streets. Maybe that's slowing down the loading.

@EdLoach: I'm looking at http://www.openstreetmap.org/?lat=51.19369&lon=5.04247&zoom=15&layers=M

I'm a newbie here. When I edit things in OMQ, is it having the same effect as editing in OSM ? In other words, are we editing the same instance of the map ?

(22 May '12, 20:02) Gilbert
1

Yes - it's the same map (I've just added something via Mapquest Open and it's appeared in OSM)

(22 May '12, 23:07) SomeoneElse ♦

Please check again now - P2 has been updated so that it no longer requests files from adobe.com, which we think might have been the problem.

(24 May '12, 22:46) Richard ♦
showing 5 of 6 show 1 more comments

Problem is still the same. See attached screenshot.alt text

permanent link

answered 28 May '12, 21:42

Gilbert's gravatar image

Gilbert
41115
accept rate: 0%

1

Very difficult to diagnose from a distance, but you might try going to http://www.macromedia.com/support/documentation/en/flashplayer/help/settings_manager03.html and reporting back your settings under the second tab ("Global Storage Settings"), the third tab ("Global Security Settings"), and the sixth tab ("Website Storage Settings" - scroll down to find www.openstreetmap.org).

(29 May '12, 09:06) Richard ♦

That did the trick. Thanks! Still slow - sometimes to the point where I wonder if I'm still connected... but that's the same on MQ Open. I guess the OSM server is just slow ? My internet connection is 30 Mb.

(29 May '12, 22:37) Gilbert

I had the same problem with Firefox and it works (for me) when I switch to private browsing (Tools/start private browsing). I don't know why but it works...

Good luck!

permanent link

answered 28 May '12, 23:15

Hugues%20F's gravatar image

Hugues F
391101119
accept rate: 0%

Hmmmm... that suggests to me that there's an issue with the Flash cookie settings. Could you try (without private browsing) the suggestion I've made under Gilbert's screenshot above, and let me know?

(29 May '12, 10:26) Richard ♦

Now, it works fine! I think there was an update that fixed the problem. So whatever I do now, it works.

I don't know who I have to thank, but thanks!

(29 May '12, 21:36) Hugues F
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×207
×73

question asked: 21 May '12, 22:20

question was seen: 4,576 times

last updated: 29 May '12, 22:37

powered by OSQA