1
1

I am using Ubuntu 11.10 32 bit. I have followed the instructions from here but am not getting any tiles on the map (localhost/osm/slippymap.html) when I select "local tiles". It works properly when I select "Mapnik" (which gets the tiles from openstreetmap). Firebug shows multiple "NetworkError: 404 Not Found - http://localhost/osm/x/xxx/xxx.png". Indeed there are no tiles in var/lib/mod_tile. When I enter "localhost/mod_tile" I get 'NoResp' on everything. When I enter render_list -f -a I get "socket connect failed for: /tmp/osm-renderd". I think the import of .osm into PostgreSQL went properly; the messages returned looked like those described here (under the Importing data into the database section) and I can see data in the database through pgAdmin. I set permissions on var/lib/mod_tile to 777. Is Mapnik not communicating with mod_tile? Contents of etc/renderd.conf is:

[renderd] stats_file=/var/run/renderd/renderd.stats socketname=/var/run/renderd/renderd.sock num_threads=4 tile_dir=/var/lib/mod_tile ; DOES NOT WORK YET [mapnik] plugins_dir=/usr/lib/mapnik/0.7/input font_dir=/usr/share/fonts/truetype/ttf-dejavu font_dir_recurse=false [default] URI=/osm/ XML=/etc/mapnik-osm-data/osm.xml ;HOST=tile.openstreetmap.org ;HTCPHOST=proxy.openstreetmap.org

I see that "DOES NOT WORK YET" but am unsure what, exactly, doesn't work since this tutorial says that one should have a working tileserver if everything goes OK.

Contents of /var/run/renderd/renderd.stats is '0' for everthing.

I'm totally new to mapping, new to PostgreSQL and fairly new to linux. Thanks for any help.

asked 06 Apr '12, 16:32

DavidLR's gravatar image

DavidLR
71226
accept rate: 0%


In the end I re-installed Ubuntu 11.10, deleting everything from the previous install. Ran all Ubuntu updates, then ran the script, installed pgAdmin, set a password and granted superuser privileges to 'www-data', changed /etc/postgresql/9.1/main/pg_hba.conf to 'trust' on both 'local alls', ran osm2psql using www-data user and password, and I now generate my own tiles. This script works perfectly on a fresh install; one that's been used and abused, no.

permanent link

answered 09 Apr '12, 23:10

DavidLR's gravatar image

DavidLR
71226
accept rate: 0%

Hi David, please give us the commande lines that resolved your problem. Thank you

(22 Feb '13, 03:18) Yahya_Romdhane

Can you explain more precisely

(22 Feb '13, 04:57) Yahya_Romdhane

I have the same problem and I resolved itbut not perfectly because I still unable to display tiles from an other computer Did you resolve this problem?

(22 Feb '13, 05:16) Yahya_Romdhane

I just had this exact problem.

I followed the step's 'ben' took in the following thread.

http://www.bitchx.com/log/osm-o/osm-o-05-May-2010/osm-o-05-May-2010-02.php

to resolve my problems i ran 'renderd -f' and saw that it was failing on www-data not have accessing to the database. (I had used my own usernames etc.. when setting everything up). I gave www-data ownership of the gis db, and now everything is running fine, and when I switch to local tiles, I have data!

permanent link

answered 06 Apr '12, 23:41

John%20Perrin's gravatar image

John Perrin
76227
accept rate: 0%

didn't work for me, but thanks. Also tried granting public all to each table, still, no good. I just re-installed everything.

(09 Apr '12, 23:16) DavidLR

Hi, I have the same problem and I resolved itbut not perfectly because I still unable to display tiles from an other computers. Did you resolve this problem?

(22 Feb '13, 05:15) Yahya_Romdhane
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×312
×231
×71

question asked: 06 Apr '12, 16:32

question was seen: 12,863 times

last updated: 22 Feb '13, 07:12

powered by OSQA