1
1

I'm a newbie to much of this, but have been trying to follow directions exactly, with no results. I'm trying to download a set of tiles for Mapping Tool on my smart phone, using JTileDownloader. Following all the directions I could find, I run JTile... and copy/past the url of the map from OpenStreetMap in Permalink format. I set the folder for the output, then click "download tiles", but my destination folder remains empty. I don't see any error messages. Any thoughts on what I'm doing wrong? I'm running version 6 of Java, and 0.6 of JTile... Thanks

asked 26 Mar '12, 20:01

GeoSh's gravatar image

GeoSh
31113
accept rate: 0%

edited 08 May '12, 17:39

stephan75's gravatar image

stephan75
12.5k453209

Please edit your question and tell us:

Do you see any progress indicator that tiles are downloaded at all?

Try to start JTiledownloader from Windows' command prompt like described at http://wiki.openstreetmap.org/wiki/JTileDownloader

As a Java app, maybe you can see any error messges there.

(27 Mar '12, 08:33) stephan75

When JTileDownloader is run directly and "download tiles" clicked, there's no progress indicator or signs of activity. Running program from a command prompt generates a file of which the first few lines are shown below. The rest are mostly more "(Unknown Source")lines.

Exception in thread "AWT-EventQueue-0" java.lang.NoSuchMethodError: java.lang.Integer.compare(II)I at org.openstreetmap.fma.jtiledownloader.datatypes.TileComparatorFactory $QuadComparator.compare(TileComparatorFactory.java:57) at org.openstreetmap.fma.jtiledownloader.datatypes.TileComparatorFactory $QuadComparator.compare(Tile

(27 Mar '12, 15:11) GeoSh

Please read the update note below (jTileDownloader 'Backport' to Java SE 5).
Some developer of the jTileDownloader decided it would be a good idea to use the latest and greatest features of Java SE 7 (aka Java v1.7.x) ignoring the fact that almost all people have Java SE 5 (aka v1.5.) or 6 (aka v1.6.) installed...and maybe don't want to upgrade to a newer version for whatever reason (maybe not yet available on the platform of the user).

The Integer.compare(x,y) is one of the new methods introduced in Java SE 7 (aka v1.7.x). See here: http://docs.oracle.com/javase/7/docs/api/java/lang/Integer.html#compare%28int,%20int%29

This can be fixed easily (changed back to the old behaviour) in about 10 minutes (the link above already shows one working option), so the application would again work with Java 6 (1.6.x). I actually backported it myself a few weeks ago when I downloaded the code and Eclipse showed me some errors, because the selected runtime for the project was Java 1.5 or 1.6. My build is currently not available anywhere and I don't have the time right now to put it on my website. The other solution would be to install Java 7 (1.7.x) which is currently required.

One other thing which not everyone knows. The 64-bit Java Runtime uses round about 1.5 x more memory than the 32-bit Java Runtime and the 64-bit version is normally not faster. Having said that I suggest to install the 32-bit version even on a 64-bit system. There might be a reason to use the 64-bit version on the 64-bit operating system but normally it's not required.

Update 1 - 2012-03-31
I'm just downloading the source code again to re-apply the fix for the problem (backport to older Java versions). I don't know when I can upload the new 0.6 release to my website...hopefully this weekend.

Update 2 - 2012-03-31
I've completed the backport. I did only very limited testing but it should work now with Java SE 5 (aka 1.5.x) and Java SE 6 (aka v1.6.x). The applied modification can be found in the package 'org.openstreetmap.fma.jtiledownloader.datatypes'. The class is 'TileComparatorFactory' and the methods changed are 'SimpleComparator.compare(Tile, Tile)' and 'QuadComparator.compare(Tile, Tile)'. Both are inner classes with a compare method.
jTileDownloader v0.6.0 'Backport' for Java SE 5 - Application (2012-03-31)
jTileDownloader v0.6.0 'Backport' for Java SE 5 - Java Source (2012-03-31)

A success report would be nice. Thank you.

permanent link

answered 29 Mar '12, 15:35

magog001's gravatar image

magog001
9632
accept rate: 100%

edited 31 Mar '12, 13:16

Thanks very much for taking the time to address my question. While I consider myself reasonably tech-savvy, when it comes to code-related issues I'm much slower. I understand from your reply that my problem is or might be related to some new technique used in Java SE 7. I see on the java website that 7 is still basically in beta, and not generally available. Unfortunately, looking at the site your link takes me to leaves me clueless about what I'd do with that info. If the above is correct, then I'll just wait for SE 7 to be released, as I'm in no particular hurry to make the downloads work. If I'm misinterpreting your response, please let em know. Thanks again.

(30 Mar '12, 00:33) GeoSh

The provided link (showing the new function) was more for (Java) developers and not for the end users. Java SE 7 (v1.7.x) has been released at least for Windows in October 2011 by Oracle. Here the Java Downloads offerings by Oracle: http://www.oracle.com/technetwork/java/javase/downloads/index.html

End-User --> Grab the Java Runtime Environment (JRE)

Developer --> Grab the Java Development Kit (JDK)...it also includes the JRE

Maybe Apple hasn't released a 'final' MacOS X release yet. If that's the case it confirms my rant above that it's a bad idea to use the latest features right away.

(30 Mar '12, 23:59) magog001
1

I added download links in my original post to my website where I placed the backport for older Java versions. Some feedback if it works or not would be nice. Thank you!

(31 Mar '12, 13:20) magog001

I thought I'd get an email anytime something new on this thread showed up, but it didn't for your followups. Very sorry for not having responded, as I just decided to take a peek into the subject today.

Yesterday I did install the (beta?) version of JRE 7 from Oracle and ran the jtiledownloader again, with results identical to before - no tiles. I will next try your application backport on a computer with JRE 6 and let you know the results.

Again, apologies for not getting back to you, and many thanks for your help.

(05 May '12, 17:51) GeoSh

No problem. With the JRE 7 from Oracle it should work with the original release. Maybe the 'old' JRE is still active? What do you get when you open a command line and run (java needs to be on the PATH to be found): java -version or java -fullversion

(07 May '12, 09:44) magog001

I haven't tried running it on a command line, but I did check Java in the control panel of that other computer which indicated version 7. In the meantime your tweaked jtiledownloader ran apparently correctly on this computer with JRE 6, as the folders and png files finally got created as expected. Thanks!

Now I'm on to the next problem with the MapTool not working properly on my Palm Pixi, but hoping to get some guidance from the developers. (Just FYI, installed the tiles in the correct folder in the phone, but MapTool app seems to pull in coordinates for Berlin, not NJ where I am.)

(07 May '12, 14:28) GeoSh

We are going off-topic now but... I've got the Pre2 and Pre3 here and I'm also a Mapping Tool user. Just downloaded the v3.9.0 this afternoon. I assume that Henk Jonas uses the Berlin coordinates (he lives there) as default when the Pixi wasn't able to get the current location yet. What is shown when you switch to "Dash2" (click)? There should be entries (coordinates) for "Start" and "Now". On "Dash1" you can scroll down to get a list of satellites currently used (they written "bold").

(07 May '12, 16:08) magog001

Should we take this off-line, or comment further here? I probably need to get an updated version, as I have no idea of what the "Dash..." is.

(07 May '12, 16:28) GeoSh

Yes we should move the Mapping Tool issue to a personal email level. As it seems there is no option here for PM just go to my website (see link above...and remove the stuff pointing to my JTileDownloader build) and once the page is loaded click on contact where an image with an email address shows up. Once I get something from you I'll reply with my real address. The "dash" stuff is also available in older versions (swipe to the left in the left area of the gesture area below the screen...each time you do that something should change...1st the buttons on the map, then the map disappears and the first dash shows up...). The rest via personal email. cu

(08 May '12, 00:57) magog001
showing 5 of 9 show 4 more comments
Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×233
×62
×4
×3

question asked: 26 Mar '12, 20:01

question was seen: 5,852 times

last updated: 08 May '12, 17:39

powered by OSQA