Hello, I have just modified some data in my city (Poznań, Poland) in JOSM editor. However when i try tu upload changes I get error: "Failed to open a connection to the remote server 'http://api.openstreetmap.org/api/0.6/'. Please check your internet connection". My Internet connection is good (I can download data) and the error lasts for about two hours now. Is there a problem with OSM server or that's sth on my side?

asked 16 Feb '12, 15:25

stachu's gravatar image

stachu
26113
accept rate: 0%

I also checked this on older version of JOSM and it's still the same. Anyone experinceing same problem?

(17 Feb '12, 15:26) stachu
1

I suspect it is your side. I've used JOSM within the last 9 hours without issues.

(18 Feb '12, 00:41) EdLoach ♦

If you try and do something very simple, like add one new tag to one node, does the problem still occur?

(21 Feb '12, 00:43) SomeoneElse ♦

The problem seems to be with network at my workplace (I checked multiple computers with diffrent JOSM versions). At my home everything is fine. I think that network admin is blocking some packets which JOSM generates (maybe some not common HTTP headers?). Do you know where I can find some info about it or anybody had similar problems? Thanks in advance Mike

(21 Feb '12, 09:02) stachu

Your workplace might be behind a proxy for internet access. You have to configure it manually in JOSM preferences.

(21 Feb '12, 10:07) Pieren

It is not behind proxy. It's just stupid filtering policy (e.g. accessing FTP servers on non standard port is not possible).

(21 Feb '12, 10:11) stachu

Well, I seem to have the same problem today. However, the changes on the other hand seem to be committed to the database anyway? When copying the address in a browser the response is: not found - so the API is down today? Any hints?

(01 Nov '12, 09:06) WernerBeckmann

There's just been a "discussion" on the #OSM IRC channel about this. Apparently JOSM is trying to close changesets twice, which wasn't noticeable until yesterday, when something else changed to make it visible. It looks like it's being dealt with.

(01 Nov '12, 10:42) SomeoneElse ♦
showing 5 of 8 show 3 more comments

Made multiple edits on 16th, 18 19 20 - no issues I personally always run JOSM UPLOADS with (advanced configuration) set to

'Upload data in chunks of objects' I set to 100

works great never had an upload issue since

permanent link

answered 21 Feb '12, 00:07

bri%20g's gravatar image

bri g
162
accept rate: 0%

Your answer
toggle preview

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here

By RSS:

Answers

Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text](http://url.com/ "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:

×507
×192
×95
×52

question asked: 16 Feb '12, 15:25

question was seen: 6,852 times

last updated: 01 Nov '12, 10:42

powered by OSQA