NOTICE: is no longer in use from 1st March 2024. Please use the OpenStreetMap Community Forum

Hi all,

I have been running the following command on Windows 7 for the last year to run the most up-to-date tested JOSM jarfile:

java.exe -jar -Xmx512M josm-tested.jar

For the last few days (from about Jan 30th 2012) i have been receiving the following exception:

'Invalid or corrupt jarfile josm-tested.jar'

I am using josm-tested version 4878

Any ideas?

I have downloaded the latest jarfiles

I am running the latest JRE: Version 6 Update 30

asked 03 Feb '12, 09:03

samlarsen1's gravatar image

accept rate: 50%

edited 03 Feb '12, 09:18

Are you sure that you've correctly downloaded the JAR file?

First, what is the size of the file? Mine is 7Mo.

permanent link

answered 03 Feb '12, 13:49

NicolasDumoulin's gravatar image

accept rate: 13%

edited 03 Feb '12, 13:50

I have downloaded from: Filesize is 2,441Kb Version 4878

(03 Feb '12, 14:21) samlarsen1

Ok, so something is wrong with your download. Which web browser are you still using? Try another one: firefox, IE, chrome, …

(03 Feb '12, 14:48) NicolasDumoulin

I was using a python script which checks the latest online version before opening JOSM & downloads a new one if the version number has increased.

It has worked successfully for at least a year, i don't know why it is now not working. I'll try to fix the python script or just download manually in the future.

Thanks for your help

(03 Feb '12, 15:23) samlarsen1

Have you tried downloading the latest jar file again, perhaps after deleting the copy you downloaded already? I'm using 4878 on Windows 7 without any problems (though give it a bit more memory -Xmx1500m).

Having said that I only seem to be on update 22, so will update and check again.

Edit: I've updated to update 30 and still all is OK.

What version did you upgrade from? A few stable releases ago I had problems starting JOSM (I don't think it was a corrupt jar message though) and had to remove my settings files and start configuring it from scratch again. I renamed the folder




just to perform the test

permanent link

answered 03 Feb '12, 09:45

EdLoach's gravatar image

EdLoach ♦
accept rate: 22%

edited 03 Feb '12, 09:51

I have downloaded the latest jarfiles a couple of times, i am thinking this might be a Java issue as i have gone back in the josm archives and downloaded previous versions that should have worked from last year and i am still getting the same problem. I have also removed my settings files which has not changed anything

(03 Feb '12, 10:05) samlarsen1

Have you tried then uninstalling Java and redownloading it? (As I did to update from 22 to 30).

(03 Feb '12, 11:31) EdLoach ♦

I've uninstalled & reinstalled java and still have the same problem. It must be a problem with my system, i will try to run some other executable jars.

(03 Feb '12, 14:20) samlarsen1

Follow this question

By Email:

Once you sign in you will be able to subscribe for any updates here



Answers and Comments

Markdown Basics

  • *italic* or _italic_
  • **bold** or __bold__
  • link:[text]( "title")
  • image?![alt text](/path/img.jpg "title")
  • numbered list: 1. Foo 2. Bar
  • to add a line break simply add two spaces to where you would like the new line to be.
  • basic HTML tags are also supported

Question tags:


question asked: 03 Feb '12, 09:03

question was seen: 3,348 times

last updated: 03 Feb '12, 15:23

NOTICE: is no longer in use from 1st March 2024. Please use the OpenStreetMap Community Forum